<!DOCTYPE html><!--[if lte IE 7]><html class="ie7" lang="en"><![endif]--><!--[if IE 8]><html class="ie8" lang="en"><![endif]--><!--[if IE 9]><html class="ie9" lang="en"><![endif]--><!--[if !IE]><!--><html lang="en"><!--<![endif]--><head><meta charset="utf-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=6', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<title>How to install Cockpit web console on Ubuntu 22.04</title>
<meta name="HandheldFriendly" content="True" />
<meta name="MobileOptimized" content="320" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="shortcut icon" href="/favicon.ico" />
<link href="https://fonts.googleapis.com/css?family=Roboto:400,400i,700,700i|Roboto+Condensed:700,700i" type="text/css" rel="preload" as="style" onload="this.rel=&#39;stylesheet&#39;" />

<style type="text/css">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</style>

<link type="text/css" href="/assets/css/main-color.css?v=cb198047ec" rel="preload" as="style" onload="this.rel=&#39;stylesheet&#39;" />
<!--[if lt IE 9]>
<link rel="stylesheet" type="text/css" href="/assets/css/grids-ie.css?v=cb198047ec">
<script src="/assets/js/html5shiv.min.js?v=cb198047ec"></script>
<![endif]-->
<link rel="icon" href="/favicon.ico" type="image/x-icon" />
<link rel="canonical" href="https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/" />
<meta name="referrer" content="no-referrer-when-downgrade" />
<link rel="amphtml" href="https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/amp/" />
<meta property="og:site_name" content="OwlHowTo " />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to install Cockpit web console on Ubuntu 22.04" />
<meta property="og:description" content="Cockpit is a web console utility that allows you to manage your server with ease, it is a essential tool when it comes to managing your server.   What can you do with Cockpit? With cockpit you can do basically anything you can do when you login normally on your server," />
<meta property="og:url" content="https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/" />
<meta property="og:image" content="https://owlhowto.com/content/images/2022/07/cockpit-login-1.jpg" />
<meta property="article:published_time" content="2022-07-04T21:10:55.000Z" />
<meta property="article:modified_time" content="2022-07-04T22:05:50.000Z" />
<meta property="article:tag" content="cockpit" />
<meta property="article:tag" content="ubuntu 22.04" />
<meta property="article:tag" content="installation" />
<meta property="article:tag" content="no cover" />
<meta property="article:publisher" content="https://www.facebook.com/owlhowto" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="How to install Cockpit web console on Ubuntu 22.04" />
<meta name="twitter:description" content="Cockpit is a web console utility that allows you to manage your server with ease, it is a essential tool when it comes to managing your server.   What can you do with Cockpit? With cockpit you can do basically anything you can do when you login normally on your server," />
<meta name="twitter:url" content="https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/" />
<meta name="twitter:image" content="https://owlhowto.com/content/images/2022/07/cockpit-login-1.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Endrit Qerreti" />
<meta name="twitter:label2" content="Filed under" />
<meta name="twitter:data2" content="cockpit, ubuntu 22.04, installation, no cover" />
<meta name="twitter:site" content="@ghost" />
<meta property="og:image:width" content="915" />
<meta property="og:image:height" content="559" />
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "OwlHowTo ",
        "url": "https://owlhowto.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://owlhowto.com/content/images/2021/06/logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Endrit Qerreti",
        "url": "https://owlhowto.com/author/owlhowto/",
        "sameAs": []
    },
    "headline": "How to install Cockpit web console on Ubuntu 22.04",
    "url": "https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/",
    "datePublished": "2022-07-04T21:10:55.000Z",
    "dateModified": "2022-07-04T22:05:50.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://owlhowto.com/content/images/2022/07/cockpit-login-1.jpg",
        "width": 915,
        "height": 559
    },
    "keywords": "cockpit, ubuntu 22.04, installation, no cover",
    "description": "\n\nCockpit is a web console utility that allows you to manage your server with\nease, it is a essential tool when it comes to managing your server.\n\nWhat can you do with Cockpit?\n\nWith cockpit you can do basically anything you can do when you login normally on\nyour server, you can manage services, manage logs, create new accounts, update\nyour system and much more, and you can do all this without typing commands\nmanually on your terminal each time you want to do something on your server. So,\ncockpi",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://owlhowto.com/"
    }
}
    </script>
<meta name="generator" content="Ghost 4.48" />
<link rel="alternate" type="application/rss+xml" title="OwlHowTo " href="https://owlhowto.com/rss/" />
<script defer="" src="/public/cards.min.js?v=cb198047ec"></script>
<link rel="stylesheet" type="text/css" href="/public/cards.min.css?v=cb198047ec" />
<meta name="p:domain_verify" content="1b889766bb1f901b040eccd1fea15924" />
<meta name="yandex-verification" content="a9e9082b0cefd5da" />
<meta name="google-site-verification" content="ZIjQUZukUATtX3u1DZKXZSyNbLo5dN8FMfSmwi0Cy5I" />
<style>
    
    div.box a{background-color:transparent !important;}
    
    li.nav-advertise-on-owlhowto{
        background-color: #ffc107;
    line-height: 20px !important;
    margin-top: 38px;
        }
    
    
    #fl{text-align:center;
    color:white;
    background-color:#3c81ff;
    padding:10px;}
    
    #fl a{color:white;
        font-size:19px;
        font-weight:bold;
    }
    
 
    
    
    #new-menu ul li a {
    color: #4e4e4e;
    text-decoration: none;
    font-style: normal;
        margin:0 !important;}
    
    #new-menu ul li a:hover {
  color:black;
    font-weight:bold;
    }
    
    div.text code, div.text pre{background-color:#3c3c3c;
    color:#e6e6e6;}
    
    div.text h2  {
   
    color: #333 !important;
}
div.text h3  {
   
    color: #333 !important;
}
    
    .meta > .tags > a {color:white !important;}
    
    
    .pagination {
    text-align: center;
    margin-top: 40px !important;
    margin-bottom: 40px !important;
}
    
    #header div.menu-wrapper, div.tags a, div.tags span, section.breaking-news div.slick, .pagination a, .pagination span, .button, .pace .pace-progress {
    background: #ff6666 !important;
}
    .pagination a, .pagination span, .pagination{color:white !important;}
    
   

    
    .title.bordered, div.text blockquote, #footer {
    border-color: #ff6666 !important;
}
    
    #header nav ul.menu>li>a{color:white !important;}
      #header nav ul.current-menu-item>li>a {color:white !important;}
    
   
    
    #header{background: white !important;}
    
    .support{margin-top:30px;
    margin-bottom:30px;}
    
    #tags {margin-top:30px;
    margin-bottom:30px;}
    
    #tags > a  {
       
    
     color: grey;      
    border-style: solid;
    border-color: #484848;
    border-width: .5px;
    padding: 8px;
    display: inline-block;
    margin: 2px;

    
    }
    
    #tags > a:hover{color:white;}
    
    post-tags a {
    
    
                display: inline-block;
                outline: 0;
                cursor: pointer;
                border-radius: 6px;
                border: 2px solid #ff4742;
                color: #ff4742;
                background: 0 0;
                padding: 8px;
                box-shadow: rgba(0, 0, 0, 0.07) 0px 2px 4px 0px, rgba(0, 0, 0, 0.05) 0px 1px 1.5px 0px;
                font-weight: 800;
                font-size: 16px;
                height: 42px;
                :hover{
                    background-color: #ff4742;
                    color: #fff;
                
                
    }
    }
    
    
    .related-tags a{
    padding: 7px;
    background-color: #e4e4e4;
    display: inline-block;
    margin: 3px;
    color: #4a4a4a;
        margin-bottom:10px;
        font-size:12px;
    
    
    }
    
  .post-tags a {
    padding: 7px;
    background-color: #e4e4e4;
    display: inline-block;
    margin: 3px;
    color: #4a4a4a;
    margin-bottom: 10px;
}
        
    
    
    a.hover-effect img, a.hover-effect span.cover{opacity:1 !important;}
    
    
    .bmc-btn {min-width:80px !important;}
    
    
    .recommended-tutorial{
    
    padding: 20px;
    background-color: #e2eeff;
   margin-top: 30px;
    margin-bottom: 30px;
    
    }
    
    
    .recommended-tutorial a{color:#673ab7;}
    
    .recommended-tutorial i{
        margin-left:3px;
    margin-right:30px;
    font-size:25px;
    }
    
    
    </style>
<style>:root {--ghost-accent-color: #15171A;}</style>
<script type="text/javascript">var ezouid = "1";</script><base href="https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 298955;
var ezdomain = 'owlhowto.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":298955,"engaged_time_visit":0,"ezcache_level":1,"ezcache_skip_code":7,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"7162c78d-46b4-456d-78ce-84ad848036d8","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":87326,"response_time_orig":601,"serverid":"44.202.246.17:15249","state":"VA","t_epoch":1657151263,"template_id":120,"time_on_site_visit":0,"url":"https://owlhowto.com/how-to-install-cockpit-web-console-on-ubuntu-22-04/","user_id":0,"word_count":896,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_298955=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["7162c78d-46b4-456d-78ce-84ad848036d8", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="enable_animations  post-template tag-cockpit tag-ubuntu-22-04 tag-installation tag-no-cover">

<div id="wrapper">

<header id="header">

<div class="top grid-container grid-parent">
<div class="social hide-on-mobile hide-on-tablet">
</div>

</div>



<div class="newmenu">

<div class="social hide-on-tablet hide-on-mobile">
</div>
<section id="new-menu">
<style>

	#header{
	background-color:#ffffff !important;

	}



		#new-menu {
		  width:100%;
		height:90px;
		background-color:#ffffff !important;
		display:block;

		}



	#new-menu	ul {



		}



		 #new-menu ul li {
		    display:inline-block ;
		    padding:0 20px;
		    float:left;
		  line-height:90px;
			margin-left:20px;


		  }

		  #new-menu ul li a {

		color:#4e4e4e;
		text-decoration: none;
		font-style:normal;
	margin-left:20px;

		    }

	#header{
		padding-top:0 !important;
	}


	#owlhowto-logo{


	}

	#owlhowto-logo img{
		height: 66px;
	    float: left;
	    display: block;
	    margin-left: 40px;
	    margin-right: 40px;
	    margin-top: 12px;
	}

	#search-box{
		float:right;
		display:block;
		line-height:90px;
	}

	#search-input{
		margin-top:24px !important;
	}

	#search-result{
		background-color:black;
		color:white;
	}

	#searchbox{
		background-color:black;
		color:white;
		padding:15px;

		margin-right:30px;

	}

	#ghost-search-field{

		background-color: black;
		    margin-right: 40px;
		    padding: 15px;
				color:white;
	}






	@media only screen and (max-width: 600px) {
	  #owlhowto-logo img {

			    display: none;
			    height: 50px;
			    margin-top: 49px;
			    margin-left: 126px;



	  }
	}




#mbmenu{
	height:41px;
	background-color:white !important;
	display:block;

}






	@media only screen and (max-width: 600px) {
	#search-box {

display:none;

	  }
	}

	@media only screen and (max-width: 600px) {
	#header {

	padding:0 !important;
	position:inherit !important;
	opacity:1 !important;
	visibility: visible !important;

	margin-right:10px !important;

	  }
	}

	@media only screen and (max-width: 600px) {
	#new-menu ul li {

		float: none;
	    padding: 8px;
	    line-height: 0;
	    margin: 11px auto;
	  }
	}

	@media only screen and (max-width: 600px) {
	#new-menu  {

		width: 100%;
		    height: 60px;
		    background-color: #ffffff !important;
		    display: block;
		    margin-top: 26px;
				text-align:center;



		}
	}





	</style>
<div id="owlhowto-logo">
<a class="blog-logo" href="https://owlhowto.com"><img src="https://owlhowto.com/content/images/2021/06/logo.png" alt="OwlHowTo" /></a>
</div>
<div id="search-box">
<input id="ghost-search-field" placeholder="Search" autocomplete="off" />
</div>
<ul id="nav">
<li class="nav-home"><a href="https://owlhowto.com/">Home</a></li>
<li class="nav-linux-mint"><a href="https://owlhowto.com/tag/linux-mint/">Linux Mint</a></li>
<li class="nav-nginx"><a href="https://owlhowto.com/tag/nginx/">Nginx</a></li>
</ul>
</section>

</div>

<div class="clear"></div>
</header>

<section class="show-results">
<style>



#ghost-search-results{

float:right;
background-color:white;
margin-top:30px;

}



#ghost-search-results a{

display:block;
font-size:15px;

color:black;
padding:30px;


}


#ghost-search-results a:hover{



color:grey;


}


</style>
<div id="ghost-search-results"></div>
</section>

<main id="single" class="main" role="main">

<div class="center content section grid-container no-cover  ">

<div class="left-content grid-parent grid-50">
<article class="post tag-cockpit tag-ubuntu-22-04 tag-installation tag-no-cover">
<header>

<div class="meta">

<div class="clear"></div>
<h1 class="title">How to install Cockpit web console on Ubuntu 22.04</h1>
<div class="post-format">
<div class="main-image"><img src="/content/images/2022/07/cockpit-login-1.jpg" /></div>
<time datetime="2022-07-04"><i class="fa fa-clock-o"></i> Jul 4, 2022</time>
<a href="#comments" class="comments alignright"><i class="fa fa-comment"></i> </a>
</div>
</div>
</header>
<section class="post-content">
<div class="text"><p></p><p>Cockpit is a web console utility that allows you to manage your server with ease, it is a essential tool when it comes to managing your server.  </p><p><strong>What can you do with Cockpit?</strong></p><p>With cockpit you can do basically anything you can do when you login normally on your server, you can manage services, manage logs, create new accounts, update your system and much more, and you can do all this without typing commands manually on your terminal each time you want to do something on your server. So, cockpit is a web-management server gui tool that will save you a lot of time when managing your server. </p><p></p><p></p><p>In this tutorial you will learn how to install Cockpit on Ubuntu 22.04</p><p></p><h2 id="step-1login-to-your-server">Step 1 - Login to your Server</h2><p></p><p>Connect to your ssh server</p><p>For example: I&#39;m logging in as oht to my server, you can install cockpit on any user you like as long as the user has sudo permissions, because you&#39;ll be using cockpit to manage your server.</p><pre><code>ssh oht@ip</code></pre><p></p><p>You can add your user to the sudo group by using  usermod</p><pre><code>sudo usermod -aG sudo USER</code></pre><p></p><h2 id="step-2update-your-system">Step 2 - Update your System</h2><p></p><p>Make sure your system is updated in order to be able to install cockpit. Update your system by using the command below </p><pre><code>sudo apt update</code></pre><p></p><p></p><h2 id="step-3install-cockpit">Step 3 -  Install Cockpit</h2><p></p><p>Simply run the command below and press enter</p><pre><code>sudo apt-get install cockpit</code></pre><p>Output:</p><pre><code>Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  cockpit-bridge cockpit-networkmanager cockpit-packagekit cockpit-storaged
  cockpit-system cockpit-ws cracklib-runtime dconf-gsettings-backend
  dconf-service dns-root-data dnsmasq-base file glib-networking
  glib-networking-common glib-networking-services gsettings-desktop-schemas
  libblockdev-mdraid2 libbluetooth3 libbytesize-common libbytesize1 libcrack2
  libdconf1 libmagic-mgc libmagic1 libndp0 libnl-route-3-200 libnm0
  libpcsclite1 libproxy1v5 libpwquality-common libpwquality-tools
  libpwquality1 libteamdctl0 network-manager network-manager-pptp ppp
  pptp-linux session-migration wamerican wireless-regdb wpasupplicant
Suggested packages:
  cockpit-doc cockpit-pcp cockpit-sosreport xdg-utils udisks2-lvm2 sssd-dbus
  pcscd avahi-autoipd libteam-utils crda wpagui libengine-pkcs11-openssl
The following NEW packages will be installed:
  cockpit cockpit-bridge cockpit-networkmanager cockpit-packagekit
  cockpit-storaged cockpit-system cockpit-ws cracklib-runtime
  dconf-gsettings-backend dconf-service dns-root-data dnsmasq-base file
  glib-networking glib-networking-common glib-networking-services
  gsettings-desktop-schemas libblockdev-mdraid2 libbluetooth3
  libbytesize-common libbytesize1 libcrack2 libdconf1 libmagic-mgc libmagic1
  libndp0 libnl-route-3-200 libnm0 libpcsclite1 libproxy1v5
  libpwquality-common libpwquality-tools libpwquality1 libteamdctl0
  network-manager network-manager-pptp ppp pptp-linux session-migration
  wamerican wireless-regdb wpasupplicant
0 upgraded, 42 newly installed, 0 to remove and 43 not upgraded.
Need to get 12.2 MB of archives.
After this operation, 34.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
</code></pre><p></p><p>Next, you&#39;ll need to confirm with Yes by pressing <code>Y</code> key and cockpit will get installed.</p><p></p><h2 id="step-4enable-cockpit-service">Step 4 - Enable Cockpit Service</h2><p></p><p>Once cockpit has been installed on your server, you need to enable the cockpit service to ensure cockpit starts automatically when your server boots up. </p><p>This is necessary because if your server fails/reboots you won&#39;t be able to connect to cockpit without restarting the service manually, so to avoid this from happening enable cockpit service via the command below and cockpit will start automatically always when server turns on.</p><p>To enable cockpit service run the command below </p><pre><code>sudo systemctl enable --now cockpit.socket</code></pre><p></p><h2 id="step-5login-to-cockpit">Step 5 - Login to Cockpit</h2><p></p><p>Cockpit runs on <code>9090</code> port, to login to Cockpit you need to navigate to your server&#39;s Public IP from your browser, simply copy and paste the url below and press enter</p><pre><code>http://127.0.0.1:9090</code></pre><p>Replace <code>127.0.0.1</code> with your server&#39;s IP</p><p>If for some reason you can&#39;t reach the port <code>9090</code> , you can open the port on ufw by using </p><pre><code>sudo ufw allow 9090</code></pre><p>And you should see the Cockpit Login Window</p><figure class="kg-card kg-image-card"><img src="https://owlhowto.com/content/images/2022/07/cockpit-login.jpg" class="kg-image" alt="" loading="lazy" width="915" height="559" srcset="https://owlhowto.com/content/images/size/w600/2022/07/cockpit-login.jpg 600w, https://owlhowto.com/content/images/2022/07/cockpit-login.jpg 915w" sizes="(min-width: 720px) 720px" /></figure><p></p><p>Now simply type your username and password and then click the Login button and you should see the cockpit panel </p><figure class="kg-card kg-image-card"><img src="https://owlhowto.com/content/images/2022/07/cockpit-webgui.png" class="kg-image" alt="" loading="lazy" width="1331" height="430" srcset="https://owlhowto.com/content/images/size/w600/2022/07/cockpit-webgui.png 600w, https://owlhowto.com/content/images/size/w1000/2022/07/cockpit-webgui.png 1000w, https://owlhowto.com/content/images/2022/07/cockpit-webgui.png 1331w" sizes="(min-width: 720px) 720px" /></figure><p>On the image above I&#39;m logged in as root which has the full access, when you login on a regular user with sudo priveleges you&#39;ll need to turn on the administrative access, to do this login to cockpit with the other user and click on the button &#34;Turn on administrative access&#34;</p><p></p><figure class="kg-card kg-image-card"><img src="https://owlhowto.com/content/images/2022/07/turn-on-administrative-access.jpg" class="kg-image" alt="" loading="lazy" width="1366" height="286" srcset="https://owlhowto.com/content/images/size/w600/2022/07/turn-on-administrative-access.jpg 600w, https://owlhowto.com/content/images/size/w1000/2022/07/turn-on-administrative-access.jpg 1000w, https://owlhowto.com/content/images/2022/07/turn-on-administrative-access.jpg 1366w" sizes="(min-width: 720px) 720px" /></figure><p></p><p>Next, enter the user&#39;s password and click &#34;Authenticate&#34;</p><figure class="kg-card kg-image-card"><img src="https://owlhowto.com/content/images/2022/07/set-password.jpg" class="kg-image" alt="" loading="lazy" width="888" height="241" srcset="https://owlhowto.com/content/images/size/w600/2022/07/set-password.jpg 600w, https://owlhowto.com/content/images/2022/07/set-password.jpg 888w" sizes="(min-width: 720px) 720px" /></figure><p>Now you have administrative access on the user.</p><p></p><p> If you get an error like &#34;User is not in the sudoers file&#34; when trying to turn on the administrative access make sure you added the user on the sudo group that I mentioned on step 1. </p><p>Then logout from cockpit and login again to the same user and the administrative access should be enabled.</p><p></p><p></p><p></p><p></p><h2 id="conclusion">Conclusion</h2><p></p><p>By now you should know what cockpit is and how to install it on Ubuntu 22.04. </p></div>
</section>
<div class="post-tags">
<a href="/tag/cockpit/">cockpit</a><a href="/tag/ubuntu-22-04/">ubuntu 22.04</a><a href="/tag/installation/">installation</a><a href="/tag/no-cover/">no cover</a>
</div>
</article>

<section class="author  no-avatar grid-container">
<h3 class="title bordered uppercase">Author</h3>
<div class="avatar grid-35 tablet-grid-30">
</div>
<div class="right grid-65 tablet-grid-70">
<h4 class="title"><a href="/author/owlhowto/">Endrit Qerreti</a></h4>
<p>Web Development, IT, Linux System Administration, Security Researcher, Computer Technician
</p>
<div class="social">
</div>
</div>
<div class="clear"></div>
</section>

<section class="related grid-container grid-parent">
<h3 class="title bordered uppercase">Related posts</h3>
<article class="previous grid-50 tablet-grid-50">
<a href="/how-to-install-atom-text-editor-on-linux-mint/" class="thumb cover opacity-effect uppercase" style="background: url(/content/images/2022/07/install-atom-text-editor-on-linux-mint-1.png);"><span><i class="fa fa-chevron-left"></i> Previous</span></a>
<div class="meta">
<div class="related-tags">
<a href="/tag/atom-text-editor/">atom text editor</a><a href="/tag/installation/">installation</a><a href="/tag/linux-mint/">Linux mint</a><a href="/tag/atom-linux-mint/">atom linux mint</a><a href="/tag/no-cover/">no cover</a>
</div>
<time datetime="2022-07-01"><i class="fa fa-clock-o"></i> Jul 1, 2022</time>
</div>
<h4 class="title"><a href="/how-to-install-atom-text-editor-on-linux-mint/">How to Install Atom Text editor on Linux Mint</a></h4>
</article>
<article class="next grid-50 tablet-grid-50">
<a href="/how-to-install-flameshot-on-linux/" class="thumb cover opacity-effect uppercase" style="background: url(/content/images/2022/07/how-to-install-flameshot-screenshot-software-on-linux.png);"><span>Next <i class="fa fa-chevron-right"></i></span></a>
<div class="meta">
<div class="related-tags">
<a href="/tag/flameshot/">flameshot</a><a href="/tag/linux/">linux</a><a href="/tag/linux-screenshot/">linux screenshot</a><a href="/tag/no-cover/">no cover</a>
</div>
<time datetime="2022-07-05"><i class="fa fa-clock-o"></i> Jul 5, 2022</time>
</div>
<h4 class="title"><a href="/how-to-install-flameshot-on-linux/">How to Install Flameshot-Screenshot Software on Linux</a></h4>
</article>
</section>
<div id="comments">
<h3 class="title bordered uppercase">Comments</h3>
<script>
var idcomments_acct = '62b5f2cd33fba46ab41dd88559796c88';
var idcomments_post_id;
var idcomments_post_url;
</script>
<span id="IDCommentsPostTitle" style="display:none"></span>
<script type="text/javascript" src="https://www.intensedebate.com/js/genericCommentWrapperV2.js"></script>
</div>


<div class="pagination">
<div class="clear"></div>
</div>

<div class="clear"></div>
</div>

<aside id="featured" class="featured hide-on-mobile grid-25 tablet-grid-50">


</aside>

<aside id="sidebar" role="complementary" class="grid-30 tablet-grid-50 push-15">
<div class="clear"></div>

<section class="widget widget_tag_cloud">
<h4 class="widget-title title bordered"></h4>
<div class="box">
</div>
<section class="box hide-on-mobile">
</section>
<div class="clear"></div>
</section>


<section class="widget widget_text">
<div class="textwidget">
</div>
<div class="clear"></div>
<div class="textwidget">
</div>
<div class="clear"></div>
</section>

</aside>

</div>

</main>

<style>



  .custom-footer {


    background-color: #0c0c0c;
    margin: 0;
    font-weight: 300;
    font-family: "Roboto";
    padding:3em;
    z-index:2;
  }


  .footer-border {
    border-bottom-style: solid;
    border-bottom-color: #ff3333;
    border-bottom-width: 2px;
    width: 24px;
margin-left: 28px;


  }

  .footer-title {
    color: white;
    margin: 0;
    padding-left: 26px;
    font-weight: 300;
    padding-top: 2em;
  }



  .links ul {
  padding-left:36px;
padding-top:20px;
    line-height: 2;


  }

  .links a {
    color: white;
    text-decoration: none;

  }

  .links a:hover {
    color: grey;
  }

.copyright{

padding:2em;
background-color:black;
border-top-color:#1d1d1d;
border-top-style:solid;
border-top-width:.5px;
text-align:center;
font-weight:300;
}

.line-footer{

border-left-style: solid;
border-left-color: #171717;
border-left-width: 1px;
height:40px;
right:50%;
margin-top:70px;
}


.sub-form{

padding:20px;

}

.v-line{

  border-left-color: #171717;
  border-left-style: solid;
  border-left-width: 0.5px;
  height:120px;
  top:0;
  bottom:0;
  margin-top:63px;
}



.sub-form p{color:white;
padding:3px;}
</style>
<section class="custom-footer">
<div class="grid-container">
<div class="grid-20 links">
<h2 class="footer-title">Links</h2>
<div class="footer-border"></div>
<ul>
<li><a href="https://owlhowto.com/about">About </a></li>

<li><a class="oht" href="https://owlhowto.com/advertise-on-owlhowto/">Advertise on OwlHowTo</a></li>
<li><a class="line" href="https://owlhowto.com/privacy-policy">Privacy Policy</a></li>
</ul>
</div>

<div class="grid-20 social-section links">
<h2 class="footer-title">Facebook Page</h2>
<div class="footer-border"></div>
<ul>
<li><a href="https://facebook.com/owlhowto" target="_blank">OwlHowTo</a></li>
<ul>
</ul></ul></div>
<div class="grid-5 v-line hide-on-mobile"></div>
<section class="tags">
<div class="grid-30  links">
<h2 class="footer-title">Tags</h2>
<div class="footer-border"></div>
<div id="tags">
<a href="/tag/htpasswd/">.htpasswd</a> <a href="/tag/etc-linuxmint-info/">/etc/linuxmint/info</a> <a href="/tag/run-nordvpn-nordvpnd-sock-not-found/">/run/nordvpn/nordvpnd.sock not found</a> <a href="/tag/var-lib-dpkg-lock-frontend/">/var/lib/dpkg/lock-frontend</a> <a href="/tag/0xc00d5212/">0xc00d5212</a> <a href="/tag/32-bit/">32 bit</a> <a href="/tag/64-bit/">64 bit</a> <a href="/tag/amazon-aws/">amazon aws</a> <a href="/tag/amazon-linux-2/">amazon linux 2</a> <a href="/tag/atom-linux-mint/">atom linux mint</a> <a href="/tag/atom-text-editor/">atom text editor</a> <a href="/tag/auth_basic/">auth_basic</a> <a href="/tag/aws/">aws</a> <a href="/tag/azure/">azure</a> <a href="/tag/bcm43228/">BCM43228</a> <a href="/tag/bootable-usb/">bootable usb</a> <a href="/tag/brave-browser/">brave browser</a> <a href="/tag/broadcom-wifi-drivers/">Broadcom Wifi Drivers</a> <a href="/tag/celluloid/">celluloid</a> <a href="/tag/centos/">centos</a> <a href="/tag/centos7/">centos7</a> <a href="/tag/centos8/">centos8</a> <a href="/tag/cinnamon-session-cinnamon/">cinnamon-session-cinnamon</a> <a href="/tag/cinnamon-session-cinnamon-not-found-falling-back-to-default/">cinnamon-session-cinnamon&#34; not found; falling back to default</a> <a href="/tag/client_max_body_size/">client_max_body_size</a> <a href="/tag/cmd/">cmd</a> <a href="/tag/cockpit/">cockpit</a> <a href="/tag/compositor/">compositor</a> <a href="/tag/could-not-get-lock/">could not get lock</a> <a href="/tag/create-multiboot-usb/">create multiboot usb</a>
</div>
</div></section>
</div>
</section></div>
<div class="grid-100 copyright">
<p>Copyright © OwlHowTo 2022</p>
</div>

<script type="text/javascript" src="/assets/js/ghost-search.min.js?v=cb198047ec"></script>
<script>
		    let ghostSearch = new GhostSearch({
		        key: 'bf42dd5c58de4d4f795122d883',
		        url: 'https://owlhowto.com',
						input: '#ghost-search-field',
						results: '#ghost-search-results',

						template: function(result) {
					             let url = [location.protocol, '//', location.host].join('');
					             return '<a href="' + url + '/' + result.slug + '">' + result.title + '</a>';


}

		    })


		</script>
<script src="https://unpkg.com/@tryghost/content-api@1.5.10/umd/content-api.min.js" defer=""></script>

<script async="" src="https://www.googletagmanager.com/gtag/js?id=UA-180932002-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-180932002-2');
</script>
<script type="text/javascript" src="/assets/js/scripts.min.js?v=cb198047ec" defer=""></script>
<!--[if !IE]><!-->
<script type="text/javascript" src="/assets/js/wow.min.js?v=cb198047ec" defer=""></script>
<!--<![endif]-->
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="owlhowto_com",_audins_did=298955;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.owlhowto_com,DomainId.298955" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=0&cb=4', false, [], true, false, true, false);</script></body></html>